Apache Log4j Vulnerability (CVE-2021-44228)

Background: The Apache Log4j utility is a commonly used component for logging requests. On December 9, 2021, a vulnerability was reported that could allow a system running Apache Log4j version 2.14.1 or below to be compromised and allow an attacker to execute arbitrary code.

On December 10, 2021, NIST published a critical Common Vulnerabilities and Exposure alert, 
CVE-2021-44228. More specifically, Apache Log4j2 2.0-beta9 through 2.12.1 and 2.13.0 through 2.15.0 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0, this functionality has been completely removed. Note that this vulnerability is specific to log4j-core and does not affect log4net, log4cxx, or other Apache Logging Services  projects.
eMAM team has identified that the eMAM NRCS integration module (eMOS) uses the log4j module. On December 15, 2021, eMAM has released a critical patch for eMOS module with Apache log4j version 2.16.0


What should I do to protect myself?

Most eMAM applications use the Windows-based .NET framework, which is safe from current vulnerabilities.  But, the eMAM NRCS integration module (eMOS) uses the log4j module.  
If you use the eMOS for newsroom workflows, please reach out to our customer service support@emamonline.com for the upgrade instructions.  
 
If you are not a newsroom customer, this article will guide you through the step-by-step process to remove the eMOS module from eMAM servers - http://support.empressmam.com/kb/a367/remove-emos-module.aspx 

We also recommend updating the 
Java and Apache versions to the latest.